How to fix 503 Error code from Webhooks response

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The user receives a 503 error code from Webhooks response even if the Webhook IPs are allowlisted for the inbound connection at their end.

Diagnosis

Try to connect to Webhook URL through Atlassian Bitbucket Proxy:

1 curl -v <Webhook URL> --proxy http://edge-outboundproxy01-prd-useast1.net.atlassian.com:8080

Cause

If we are unable to connect to Webhook URL using the above command (HTTP/1.1 503 Service Unavailable) that means one of the following:

  • Bitbucket IPs are not allowlisted as Inbound traffic at the user end;

  • The IPs are allowlisted, but the port on which Webhook is running is not open for the inbound traffic.

Solution

Confirm that the following IPs are allowlisted as Inbound traffic:

1 2 IPv4: 18.205.93.0/25, 18.234.32.128/25, and 13.52.5.0/25 IPv6: 2406:da00:ff00::0/96*

Additionally, confirm these IPs are open for the port on which Webhook URL is running.

  • This could be done using the nmap command.

Updated on April 24, 2025

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