Email notifications include the workspace name instead of the user's public name

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

  • This article explains the scenario where a user's Bitbucket public name is not displayed in notification emails generated from activities such as committing to a repository or updating a branch that is part of a pull request.

  • This behavior may cause confusion and result in the user receiving their own notifications.

Environment

Bitbucket Cloud, when using a workspace Access key to perform pushes.

Cause

  • The cause of the missing Bitbucket user's public name in notification emails lies in the distinction between the commit author and the user who authenticated the push.

  • When Bitbucket sends an email notification, the content displays the commit and author information, which is based on the user that has executed the "git commit" command on the local copy of the repository (this comes from local git config settings - see Configure your username for commits).

  • This field should correctly show the public name of the author of the commit.

  • However, the title of the email displays the public name of the user that authenticated the push. In cases where a user utilizes a workspace SSH Access key (Workspace Settings > Access keys), the workspace itself acts as the authenticated user. This results in the title showing "<workspace> pushed a commit to the repository" instead of the actual user's Bitbucket public name.

  • This discrepancy between the author of the commit and the authenticating user is what can cause the email notification to include the workspace name instead of the user's public name.

Solution

  1. Identify the affected users. This can be done by comparing the public workspace SSH keys (Workspace Settings > SSH keys) with the local machine configuration of each user on your workspace.

    The command below can be used to list all keys under a user's machine on Linux, MacOSX and Windows (using git bash for Windows):

    1 cat ~/.ssh/*.pub
    1. If the key matches, then the user is affected, and should proceed with the next steps;

    2. If the key does not match, then the user in question is not affected;

  2. Each affected user needs to create their own SSH key using the steps from Configure SSH | Bitbucket Cloud

  3. Once their personal SSH key is created, the affected users need to add it to their profiles by navigating to the gear icon in the top right corner > Personal Settings > SSH Keys.

If the above instructions do not assist in resolving the issue, please raise a support ticket or raise a community support ticket for further assistance with this.

Updated on April 8, 2025

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