A user group is not appearing in branch restriction search results

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When trying to add a certain group to branch restrictions, the group was not visible in the search results while other groups were.

Diagnosis

To diagnose the issue, follow these steps:

  1. Navigate to repository settings and clickRepository permissions under General.

  2. Check if the group has access to the repository.

If the group has access to the repository, check the group's permission.

Cause

The group was not part of the repository. Therefore, it cannot be added to the branch restrictions.

Solution

To fix the issue, add the group to the repository by clicking Add users or groups on the Repository permissions page.

If the group already exists, make sure it has at least Write permission, as this is a required permission for groups to be added to branch restrictions.

Updated on April 15, 2025

Still need help?

The Atlassian Community is here for you.