Windows build artifacts are not copied

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The build completes successfully, the files are produced but the build agent doesn't find the files. This is an intermittent problem.

If the build plan is modified to list all the files, we can confirm that all the files are present, but the agent is not able to find them. In the following example, though the French and Japanese files are present, the agent couldn't find them.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 build 17-May-2013 13:01:56 C:\Users\ssetayeshfar\bamboo-agent-home\xml-data\build-dir\PK-DESKTOP-JOB1\Output>dir *.exe build 17-May-2013 13:01:56 Volume in drive C has no label. build 17-May-2013 13:01:56 Volume Serial Number is 60-5C build 17-May-2013 13:01:56 build 17-May-2013 13:01:56 Directory of C:\Users\ssetayeshfar\bamboo-agent-home\xml-data\build-dir\PK-DESKTOP-JOB1\Output build 17-May-2013 13:01:56 build 17-May-2013 13:01:56 05/17/2013 01:01 PM 5,576,536 P_Policy_1.00.0018_x86_en.exe build 17-May-2013 13:01:56 05/17/2013 01:01 PM 5,759,352 P_Policy_1.00.0018_x86_fr.exe build 17-May-2013 13:01:56 05/17/2013 12:56 PM 25,691,352 PK_1.00.0018_x64_en.exe build 17-May-2013 13:01:56 05/17/2013 12:57 PM 26,272,400 PK_1.00.0018_x64_fr.exe build 17-May-2013 13:01:56 05/17/2013 12:56 PM 26,547,920 PK_1.00.0018_x64_jp.exe build 17-May-2013 13:01:56 05/17/2013 12:58 PM 21,533,224 PK_1.00.0018_x86_en.exe build 17-May-2013 13:01:56 05/17/2013 12:59 PM 22,115,680 PK_1.00.0018_x86_fr.exe build 17-May-2013 13:01:56 05/17/2013 12:57 PM 22,391,248 PK_1.00.0018_x86_jp.exe build 17-May-2013 13:01:56 05/17/2013 12:58 PM 27,260,448 Secure_1.00.0018_x64_en.exe build 17-May-2013 13:01:56 05/17/2013 12:58 PM 26,381,896 Secure_1.00.0018_x64_fr.exe build 17-May-2013 13:01:56 05/17/2013 12:57 PM 26,261,808 Secure_1.00.0018_x64_jp.exe build 17-May-2013 13:01:56 05/17/2013 12:57 PM 22,880,064 Secure_1.00.0018_x86_en.exe build 17-May-2013 13:01:56 05/17/2013 12:56 PM 22,224,832 Secure_1.00.0018_x86_fr.exe build 17-May-2013 13:01:56 05/17/2013 12:59 PM 22,104,760 Secure_1.00.0018_x86_jp.exe build 17-May-2013 13:01:56 14 File(s) 303,001,520 bytes build 17-May-2013 13:01:56 0 Dir(s) 11,124,547,584 bytes free simple 17-May-2013 13:01:56 Finished task 'List Output' simple 17-May-2013 13:01:56 Running post build plugin 'Artifact Copier' simple 17-May-2013 13:01:56 Publishing an artifact: English Installer simple 17-May-2013 13:01:59 Finished publishing of artifact Job artifact: [English Installer], pattern: [*_en.exe] anchored at[Output] in 2s simple 17-May-2013 13:01:59 Publishing an artifact: French Installer error 17-May-2013 13:02:09 Unable to publish artifact [French Installer]: simple 17-May-2013 13:02:09 Finished publishing of artifact Job artifact: [French Installer], pattern: [*_fr.exe] anchored at[Output] in 9s simple 17-May-2013 13:02:09 Publishing an artifact: Japanese Installer error 17-May-2013 13:02:13 Unable to publish artifact [Japanese Installer]: simple 17-May-2013 13:02:13 Finished publishing of artifact Job artifact: [Japanese Installer], pattern: [*_jp.exe] anchored at[Output] in 4s ....

Cause

This problem can be caused by:

  1. Having the "Large Send Offload V2 (IPv4)" enabled

  2. Connection problems between Bamboo server and the agent

  3. Anti-virus scanner scanning the the agent home directory and the Bamboo server directory

Workaround

  1. Check that the user running the plan has admin permissions. Based on this document, if running Bamboo as a Windows service, the user has to be a local admin account: Running Bamboo service on Windows as the local user.

  2. Check for intermittent connection problems between Bamboo server and the agent. If there is a proxy server or firewall between Bamboo server and the remote agent, by pass it entirely for the sever-agent communication

  3. If an anti-virus scanner is running on the server that scans through the artifact directory, disable the antivirus scanner from scanning the agent home directory and the Bamboo server directory.

  4. Check the advanced configuration settings of the network connection on the Windows build agent system and turn OFF the option called "Large Send Offload V2 (IPv4)". This option is ON by default.

  5. Verify that the "bamboo.jms.broker.client.uri" in bamboo.cfg.xml file (under <bamboo-home> directory) is the same as the Bamboo base URL (under Administration >> General Configuration):

    1 2 <property name="bamboo.jms.broker.client.uri">failover:(tcp://_Bamboo_Base_URL_:54663?wireFormat.maxInactivityDuration=300000)?maxReconnectAttempts=10&amp;initialReconnectDelay=15000</property> <property name="bamboo.jms.broker.uri">tcp://0.0.0.0:54663?wireFormat.maxInactivityDuration=300000</property>
Updated on April 8, 2025

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