UPM shows Page Not Found when accessed from Navigation menu
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When accessing Administration >> Add-ons
and then clicking the Manage Add-ons or Find Add-ons links, the Universal Plugin Manager (UPM) returns a "Page not found" (404) error instead of loading the page.
Cause
This is caused by the Application's base URL configured in Administration >> Overview >> General configuration
being set incorrectly, with the URL commonly appearing as <original base url>/setup/setupGeneralConfiguration.action;jses
.
Resolution
Please update your Base URL, in Administration >> Overview >> General configuration
to match the URL that you use to access Bamboo. If you have Bamboo behind a reverse proxy, please be sure to use the proxy URL.
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