Upgrade Task 51602 fails: pad block corrupted

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When upgrading Bamboo to 6.0.x from 5.15 or lower, the upgrade fails with the following appearing in the atlassian-bamboo.log:

1 2 3 4 5 6 7 8 9 2017-06-12 09:35:13,278 INFO [16-UpgradeTaskBackgroundThread:pool-32-thread-1] [AbstractUpgradeManager] ---------------------------------------------------------------------------------------- 2017-06-12 09:35:13,278 INFO [16-UpgradeTaskBackgroundThread:pool-32-thread-1] [AbstractUpgradeManager] 51602 : Re-encrypting SMTP mail server password using new encryption service (bootstrap) 2017-06-12 09:35:13,278 INFO [16-UpgradeTaskBackgroundThread:pool-32-thread-1] [AbstractUpgradeManager] ---------------------------------------------------------------------------------------- 2017-06-12 09:35:13,294 ERROR [16-UpgradeTaskBackgroundThread:pool-32-thread-1] [AbstractUpgradeManager] java.lang.RuntimeException: org.bouncycastle.crypto.InvalidCipherTextException: pad block corrupted java.lang.RuntimeException: org.bouncycastle.crypto.InvalidCipherTextException: pad block corrupted ... Caused by: org.bouncycastle.crypto.InvalidCipherTextException: pad block corrupted ... 2017-06-12 09:35:13,294 INFO [16-UpgradeTaskBackgroundThread:pool-32-thread-1] [AbstractUpgradeManager] Completed task 51602 successfully.

Cause

This issue occurs when Bamboo is unable to decrypt the mail server password. This can occur due to a previously failed upgrade.

Resolution

If there is a mail server configured in Bamboo, please do the following:

  1. Stop Bamboo

  2. Open <bamboo-home>/bamboo-mail.cfg.xml

  3. Update the password field so that it reads

    1 <password></password>
  4. Start Bamboo

  5. Finally, once you are able to start Bamboo, please update the Mail server configuration from Administration >> Overview >> Mail server

Updated on April 8, 2025

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