Universal Plugin Manager is Malfunctioning due to "Entry type not found for upm.auditLog.upgrade.plugin.failure"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

UPM is malfunctioning with the following error in the UI:

1 Entry type not found for upm.auditLog.upgrade.plugin.failure

The following appears in the atlassian-Bamboo.log:

1 java.lang.IllegalArgumentException: Entry type not found for upm.auditLog.upgrade.plugin.failure

Cause

  • It's a bug affecting UPM 2.0 UPM-1733 that is fixed in UPM 2.0.3 and higher.

  • Somehow the audit logging of UPM gets corrupted

Workaround

  1. Backup Bamboo database for safety purpose.

  2. Remove UPM audit logging manually by running the following SQL query against Bamboo database:

    1 DELETE FROM BANDANA WHERE BANDANA_KEY like '%com.atlassian.upm.%';
  3. Restart Bamboo

Updated on April 11, 2025

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