Universal Plugin Manager hung installing add-on

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptom

UPM is hung install a plugin and the UI appears like below in Bamboo:

(Auto-migrated image: description temporarily unavailable)

Cause

A installation record was not removed from the bandana table in Bamboo's database. You can verify this using the following database query which will return any plugin in the INSTALLING stage.

1 SELECT * FROM BANDANA WHERE SERIALIZED_DATA LIKE '%INSTALLING%' AND BANDANA_KEY LIKE '%com.atlassian.upm.impl.PluginManagerPluginAsynchronous%';

Ensure Bamboo is shutdown when running query to avoid false positives. 

Resolution

Remove the INSTALLING record from the database and attempt to reinstall the application.

It's always good practice to backup the database before editing!

  1. Stop Bamboo

  2. Backup database

  3. Run query to remove record:

    1 DELETE FROM BANDANA WHERE SERIALIZED_DATA LIKE '%INSTALLING%' AND BANDANA_KEY LIKE '%com.atlassian.upm.impl.PluginManagerPluginAsynchronous%';
  4. Start Bamboo

  5. Reinstall Add-on

Updated on April 8, 2025

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