Unable to run pre-bootstrap upgrade tasks as your support period has ended

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After installing / starting Bamboo, the following messages are shown in the User Interface (UI):

  • You cannot access Bamboo at present.

  • Bamboo bootstrap failed: Unable to run pre-bootstrap upgrade tasks as your support period has ended.

Bamboo error page being displayed from failure of startup.

The "bootstrap failed" message also appears in atlassian-bamboo.log

1 Bamboo bootstrap failed: Unable to run pre-bootstrap upgrade tasks as your support period has ended. Please contact Atlassian and https://support.atlassian.com

Cause

Bamboo is loading an expired license key during startup. This error occurs when a customer has two licenses in their account, but the expired license is applied to Bamboo.

The property below in your <Bamboo_Home>/bamboo.cfg.xml file contains the expired license:

1 <property name="license.string"> (valid license value here) </property>

Solution

  1. Stop your Bamboo instance

  2. Backup the bamboo.cfg.xml file somewhere else on your file system

  3. Login to MyAtlassian

  4. Retrieve the valid license key

  5. Copy and paste the new license key in the property below, overwriting the one that expired:

    1 <property name="license.string"> (valid license value here) </property>
  6. Restart your Bamboo instance

Updated on April 10, 2025

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