Tasks do not run on agents due to Plugin availability errors
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
When using Remote agents, you may occasionally see Tasks fail with errors such as:
1
Error occurred while executing the build for <build name ###> (PROJ-PLAN-JOB-###) : Plugin <plugin key> not available
or:
1
Could not execute task '<task name>' no Plugin with key '<plugin key>' is installed.
Diagnosis
If your <bamboo-agent-home>/atlassian-bamboo-agent.log
has multiple JVM IDs running at the same time, this article applies. For example:
1
2
3
4
5
6
7
INFO | jvm 1 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,438 INFO
INFO | jvm 1 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,439 INFO
INFO | jvm 56 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,436 INFO
INFO | jvm 1 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,532 INFO
INFO | jvm 1 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,533 INFO
INFO | jvm 56 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,531 INFO
INFO | jvm 56 | 2017/04/24 05:21:12 | 2017-04-24 05:21:12,629 INFO
Cause
This is often caused by multiple Remote agents sharing the same Bamboo Agent Home directory. When new agents start up, the plugin cache within the agent home directory is cleared and reloaded from the server, which can cause these plugins to not be found by one of the agent processes.
Solution
Resolution
Please ensure that each Remote Agent has its own Home directory.
Create new Bamboo Agent Home directories so that every agent on the server has its own Home directory:
Was this helpful?