service proxy has been destroyed
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When a build has been queued, or any action that interacts with a Bamboo plugin has been performed, the action fails and the following appears in the Build log and/or atlassian-bamboo
.log:
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com.atlassian.bamboo.repository.RepositoryException: org.eclipse.gemini.blueprint.service.importer.ServiceProxyDestroyedException: service proxy has been destroyed
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Caused by: org.eclipse.gemini.blueprint.service.importer.ServiceProxyDestroyedException: service proxy has been destroyed
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Cause
This is caused by plugins being uninstalled or deactivated. There is a Bamboo thread that is still using that plugin, and since the plugin is no longer active, the connection is destroyed.
Resolution
Since the plugins are initialized on Bamboo startup, please restart Bamboo, and any Remote agents, to resolve this issue.
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