Rerun Build not appearing in Agent's Recent build history

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

If a build fails, is rerun, and is dispatched to a different agent, the build will appear to have disappeared from the Recent Build list.

Diagnosis

Diagnostic Steps

  1. Please verify the QUEUE_ID of the Agent where you expect the Build to be listed from the QUEUE table in the Bamboo database:

    1 2 3 SELECT QUEUE_ID FROM QUEUE WHERE TITLE = '<agent-name>';
  2. Please review the Build Result Summary of the missing Build

    For example, if the Build has Build Key PROJ-PLAN, and Job keys of PROJ-PLAN-JOB1, PROJ-PLAN-JOB2, etc, and was Build number 10:

    1 2 3 4 SELECT BUILD_AGENT_ID FROM BUILDRESULTSUMMARY WHERE BUILD_KEY LIKE 'PROJ-PLAN%' AND BUILD_NUMBER = 10;
  3. Compare the output of queries 1 and 2. If they are different, this article applies.

Cause

The BUILD_AGENT_ID column of BUILDRESULTSUMMARY, which populates the Recent Builds list, is overwritten on each rerun of a given build.

Solution

Resolution

Using the output of Diagnostic step 2, you can run the following database query to find the Agent where the Build will be listed:

1 2 3 SELECT TITLE FROM QUEUE WHERE QUEUE_ID = '<agent-id>';

Please check that agent's Build History for the Build.

Updated on April 7, 2025

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