Remote Desktop Connection password is not (yet) available on Bamboo EC2
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
After starting an elastic instance the following message is displayed:
"Remote desktop connection password is not (yet) available. If password randomisation is enabled on this image, it should become available within 15 minutes of startup."
but after waiting more than 15 minutes the password is still unavailable.
Environment
Using Bamboo EC2: Default Image EBS x86_64 (windows)
The server log shows no exceptions
Cause
The elasticbamboo.pk key is missing on the bamboo-home/xml-data/configuration directory.
The AWS key pair that is needed for Bamboo to decrypt the RDC password is missing from the instance. Normally it's created automatically, but if the AWS credentials were used on another Bamboo instance it may not have.
It's normal to have no private key on Bamboo but it will be required for Bamboo to decrypt the RDC password.
Resolution
Follow the steps on Obtaining AWS Key Pair to access Amazon Elastic Instances to recreate the keypair (unless you already have the key saved locally somewhere).
For adding the Key to a Cloud instance you'll have to upload the key to the WebDAV share and contact Support to add it for you on Bamboo
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