Remote Agent is loading on Bamboo UI never finishes

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When browsing to the Cog icon >> Agents, a Remote Agent is stuck, never added to the Agent list and the following message is shown on the UI:

A remote agent is loading on 192.168.2.112 (192.168.2.112)

Diagnosis

There could be quite a number of underlying root causes. Be sure to check the $BAMBOO_AGENT_HOME/atlassian-bamboo-agent.log on the Remote Agent to see if there is more detail on why the Agent hasn't been able to fully establish a connection.

Resolution

Here's some generic steps you can follow to solve the most common types of issues that prevent the agent from connecting:

  1. Run through the Diagnosing Remote Agent Connectivity steps on the following guide: Troubleshooting Remote Agents

  2. Ensure that the Remote Agent is running on a server with latest supported JDK (not JRE) per our Supported Platforms

  3. If this doesn't help, please raise a ticket with us at https://support.atlassian.com/ and attach a Bamboo Support Zip as well as the Remote Agent log from $BAMBOO_AGENT_HOME/atlassian-bamboo-agent.log

Updated on September 25, 2025

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