New users or groups added to the external user directory are not available in Bamboo
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
New users or groups added to the external user directory are not available in Bamboo after executing synchronisation. The last synchronisation status and Cog icon>Overview>User Directories page mentions: "Synchronisation failed. See server logs for details."

Environment
Bamboo 6.6+ instance connected to any external user directory (LDAP, Active Directory, Jira, Crowd...)
Diagnosis
java.lang.OutOfMemoryError errors can be found at the atlassian-bamboo.log
file:
1
2
ERROR [JobLauncher] Scheduled job with ID 'com.atlassian.crowd.manager.directory.monitor.poller.DirectoryPollerManager' failed
com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.OutOfMemoryError: GC overhead limit exceeded
Cause
The user synchronisation uses heap memory to process the data coming from the external user directory, if Bamboo does not have enough heap space to accommodate this data, the synchronisation will fail and new users will not be available.
Solution
Stop Bamboo
Increase the heap memory in Bamboo instance by changing the configurations below:
Linux: JVM_MINIMUM_MEMORY and JVM_MAXIMUM_MEMORY parameters
Windows: Initial memory pool and Maximum memory pool options
Start Bamboo back
ℹ️ For more information on how to change these configurations, please see this article: Configuring your system properties.
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