Manage log file size increase in Bamboo due to Prometheus exporter plugin

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Prometheus integration with Bamboo may persist post-uninstallation, causing severe log messages and increasing the size of the localhost.log file, which consumes disk space.

Environment

The solution has been validated in Bamboo Data Center 9.6.7 but may be applicable to other versions.

Diagnosis

Identifying Prometheus requests causing Bamboo log file growth

You may notice a significant increase in disk space consumption, particularly in the <bamboo-install>/logs/localhost.log file, which contains the following SEVERE messages:

13-May-2025 11:32:34.952 SEVERE [http-nio-8085-exec-31] org.apache.catalina.core.StandardHostValve.custom Exception Processing [ErrorPage[errorCode=404, location=/404.action]] javax.servlet.ServletException: Resource loading not supported, use the StrutsPrepareAndExecuteFilter instead. at org.apache.struts2.dispatcher.servlet.StrutsServlet.service(StrutsServlet.java:78) at javax.servlet.http.HttpServlet.service(HttpServlet.java:623)

While the message itself may not provide much insight into the error, cross-referencing it with the {{<bamboo-home>/logs/atlassian-bamboo-access.log}} at the same timestamp reveals a request originating from the Prometheus server:

2025-05-13 11:32:34,949 INFO [http-nio-8085-exec-6 url: /plugins/servlet/prometheus/metrics] [AccessLogFilter] 172.x.x.x - GET https://<bamboo_URL>/plugins/servlet/prometheus/metrics?token=0Z3UCXzuTv50zvg0eAkfgCXzuTv5Z7Rw5qa 985954kb

Cause

This indicates that the Prometheus server is still attempting to access Bamboo, contributing to the log file growth as it can't get a response from Bamboo.

Solution

Removing Prometheus settings to resolve Bamboo log file growth

  1. Ensure Complete Removal of Settings: Verify that all settings related to Prometheus have been removed from both the Bamboo and Prometheus server sides.

  2. Cross-Check Configuration Files: Double-check the <bamboo-install>/bin/setenv.sh file and any other configuration files to ensure no remnants of Prometheus settings remain.

  3. Restart Services: After confirming the removal of all settings, restart both the Bamboo and Prometheus services to ensure changes take effect.

Updated on June 5, 2025

Still need help?

The Atlassian Community is here for you.