IM server client failed to startup

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After adding a IM server in Bamboo, the IM server fails to start.

Cause

Bamboo performs JNDI lookup when setting up IM server. If IM server host is not a resolvable domain the setup may fail with a similar exception;

1 2 3 4 5 6 7 2021-10-10 20:29:18,330 WARN [AtlassianEvent::0-BAM::EVENTS:pool-2-thread-3] [DNSUtil] Exception while resovling SRV records for domain.com. Consider adding '_xmpp-(server|client)._tcp' DNS SRV Records javax.naming.NameNotFoundException: DNS name not found [response code 3]; remaining name '_xmpp-client._tcp.domain.com' at com.sun.jndi.dns.DnsClient.checkResponseCode(DnsClient.java:660) at com.sun.jndi.dns.DnsClient.isMatchResponse(DnsClient.java:578) at com.sun.jndi.dns.DnsClient.doUdpQuery(DnsClient.java:426) at com.sun.jndi.dns.DnsClient.query(DnsClient.java:211) at com.sun.jndi.dns.Resolver.query(Resolver.java:81)

Solution

  1. Ensure the IM Server host name is resolvable from the machine hosting Bamboo Server

  2. Create a record with the proper DNS server information.

    a. for a Linux machine add the record e.g. 192.168.0.1 domain.com in /etc/resolv.conf and on Windows C:\Windows\System32\drivers\etc\hosts

Updated on April 8, 2025

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