Error 'Can't connect to X11 window server' is reported during Server Startup

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following message is being displayed in the Bamboo Server log file, making the application startup or the database configuration fail:

1 java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.

Cause

The current machine does not have all the graphical support that the Bamboo libraries demand.

Resolution

1. Add the following setting to the bamboo.sh RUN_CMD variable:

1 -Djava.awt.headless=true

2. Ensure that Bamboo is using a full version of one of the supported JDKs (JRE is not enough).

Updated on April 8, 2025

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