Cannot install Bamboo - no JDK installed
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
After Bamboo installation (downloading the Standalone archive, extracting data, and from BAMBOO_INSTALL/webapp/WEB-INF/classes/bamboo-init.properties
file pointing to an empty BAMBOO_HOME
directory) Bamboo cannot start up to run the setup wizard. Here is the result:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
root@v1 /opt/atlassian/bamboo # ./bamboo.sh start
Starting Bamboo:
STARTED Bamboo Wed Mar 6 12:42:02 CET 2013
Bamboo running, pid=9929
root@v1 /opt/atlassian/bamboo # nohup: redirecting stderr to stdout
root@v1 /opt/atlassian/bamboo # ./bamboo.sh status
Bamboo with pid=9929 is not running - removing old pidfile
Bamboo is currently not running.
root@v1 /opt/atlassian/bamboo # cat webapp/WEB-INF/classes/bamboo-init.properties
## You can specify your bamboo.home property here or in your system environment variables.
bamboo.home=/home/bamboo
root@v1 /opt/atlassian/bamboo # ls -ls /home/bamboo
total 0
root@v1 /opt/atlassian/bamboo #
Cause
There is no JDK installed.
Resolution
Please refer to the Supported Platforms page and install a supported JDK to be able to run Bamboo.
Was this helpful?