Build <key> had to be cancelled: it was marked as in progress in DB but Bamboo has no record of this build
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Occasionally builds never stop running. The build will appear to be running indefinitely thus blocking the agent from taking other builds. In some cases, we have to restart the agent/server to get this agent released. The following stack trace is reported in the logs:
1
Build <key> had to be cancelled: it was marked as in progress in DB but Bamboo has no record of this build
Cause
The cause of this issue may be:
The agent dies while processing a build
The server still processes a build that was produced by an agent that went offline
The agent connectivity was interrupted
The agent or server exhausts resources (OOM errors)
Resolution
Upgrade Bamboo to 5.11.3 or newer versions.
Was this helpful?