Bamboo throws Internal Server Error while no space left on the PostgreSQL database server device

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Bamboo throws an Internal server Error when saving information such as deployment or project or plan or variables.

Diagnosis

You will be able to see the below sample error "could not extend file "base/16395/17147": No space left on device"  in the <BAMBOO_HOME>/logs/atlassian-bamboo.log file.

SQL exception

1 2021-12-10 10:30:19,033 ERROR [https-openssl-nio-443-exec-12] [SqlExceptionHelper] Batch entry 1 insert into VARIABLE_DEFINITION (VARIABLE_KEY, VARIABLE_VALUE, VARIABLE_TYPE, PLAN_ID, PROJECT_ID, ENVIRONMENT_ID, DEPLOYMENT_VERSION_ID, VARIABLE_DEFINITION_ID) values ('planRepository.branchDisplayName', 'main/service-changes', 'VERSION', NULL, NULL, NULL, 270467073, 270630934) was aborted: ERROR: could not extend file "base/16395/17147": No space left on device

Cause

Usually, insufficient Database server disk space can cause this issue while saving the data to the database.

Solution

  • Clean up or increase disk space in your Database server.

  • Add database server disk space monitoring mechanisms to prevent this in the future. 

Updated on March 18, 2025

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