Bamboo startup or runtime error due to ORA-00257 archiver error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Bamboo doesn't start up or has a runtime error. The following message appears in the atlassian-bamboo.log file:

1 2 [BasicResourcePool] com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@30fc16d3 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (30). Last acquisition attempt exception: java.sql.SQLException: ORA-00257: Archiver error. Connect AS SYSDBA only until resolved.

or just

1 ORA-00257: Archiver error. Connect AS SYSDBA only until resolved.

Cause

The ORA-00257 error is thrown by Oracle when the archive destination disk or volume is full. Here's the cause taken from the Oracle website:

The archiver process received an error while trying to archive a redo log. If the problem is not resolved soon, the database will stop executing transactions. The most likely cause of this message is the destination device is out of space to store the redo log file.

Resolution

  1. Check the available space on the filesystem where the Oracle archive redo logs are stored. This can be done with the following SQL query:

    1 show parameter log_archive;
  2. If the disk is full, try to free space using any of the following methods:

    • Compressing older files.

    • Removing older archives.

    • Adding more storage.

There's an archived thread on Oracle community that goes over the troubleshooting in more detail.

Updated on April 8, 2025

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