Bamboo remote agent hostname in System Properties tab is showing an unexpected value

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Bamboo Administration >> Agents >> (remote agent) >> System properties (tab) is showing an unexpected (or incorrect / wrong) value for hostname.

For example, on the below tab:

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Cause

The Java API used by the Bamboo remote agent will attempt to resolve the canonical hostname of the IP Address on the preferred network interface. It may not always match the hostname set on the machine or previously saved as the agent name into $BAMBOO_AGENT_HOME/bamboo-agent.cfg.xml

In the above example, ip-192-168-1-66.ap-southeast-2.compute.internal is resolved by the DNS lookup for 192.168.1.66.

Solution

Confirm with nslookup whether the DNS resolution for the reported IP address matches the hostname reported. If it does and it's unexpected, you'll need to correct it within your DNS resolver.

Otherwise it may be an incorrect mapping in your hosts file (/etc/hosts or C:\Windows\System32\Drivers\etc\hosts)

Updated on April 8, 2025

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