Bamboo fails to index

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Bamboo may complain about not being able to index after

  • Removing plans

  • Build completion

  • ...

1 2 com.atlassian.bonnie.LuceneException: org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: SimpleFSLock@C:\bamboo\index\write.lock at com.atlassian.bonnie.ConcurrentLuceneConnection.constructIndexWriter(ConcurrentLuceneConnection.java:551)

Cause

Bamboo maintains a Lucene index. While indexing bamboo obtains a write lock on the index directory. If bamboo is terminated forcefully or shut down before the index completes the write lock file remains. After restarting bamboo when the next index operation commences it cannot complete because the index directory is locked

Resolution

Delete the write.lock file in <bamboo-home>/index and re-index bamboo.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.