Bamboo Crashes Due to Insufficient Disk Space and Truncated bamboo.cfg.xml File

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Bamboo or the server on which it resides crashes. As a result, the bamboo.cfg.xml file gets truncated to a zero kb file. In contrast, the other folders within <bamboo-home> remain intact. The following appears in the atlassian-bamboo.log:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 2011-05-09 13:32:06,318 ERROR [main] [DefaultAtlassianBootstrapManager] Home is not configured properly: com.atlassian.config.ConfigurationException: Failed to parse config file: Error on line -1 of document  : Premature end of file. Nested exception: Premature end of file. 2011-05-09 13:32:06,324 FATAL [main] [BootstrapLoaderListener] An error was encountered while bootstrapping Bamboo (see below): Unable to bootstrap Bamboo: Failed to parse config file: Error on line -1 of document  : Premature end of file. Nested exception: Premature end of file. java.lang.IllegalStateException: Unable to bootstrap Bamboo: Failed to parse config file: Error on line -1 of document  : Premature end of file. Nested exception: Premature end of file.     at com.atlassian.bamboo.setup.BootstrapLoaderListener.contextInitialized(BootstrapLoaderListener.java:63)     at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)     at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)     at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)     at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)     at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)     at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)     at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)     at org.eclipse.jetty.server.Server.doStart(Server.java:243)     at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)     at com.atlassian.bamboo.server.Server.main(Server.java:77)

Cause

The system ran out of disk space. This can also happen due to folder permissions.

Resolution

  1. Setup a new instance and ensure the setup is successful;

  2. Copy the bamboo.cfg.xml over to the old instance and make sure the license used is valid;

  3. Make the necessary changes such as the connection url to match the configuration in the older instance.

Updated on April 8, 2025

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