Bamboo build/deployment fails to download artifacts

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Bamboo repeatedly fails to download an artifact from the same plan.

Environment

Any Bamboo supported version.

Diagnosis

When a build/deployment tries to download an artifact, the action will fail and in the build/deployment log we will see a message similar to this one:

Build/deployment log

1 2 simple 08-Feb-2022 11:38:26 Preparing to download plan result PROJ-PLAN-1 artifact: Non required shared artifact: [artifact_name], pattern: [*] anchored at: [artifact_name] error 08-Feb-2022 11:38:26 Unable to download artifact Non required shared artifact: [artifact_name], pattern: [*] anchored at: [artifact_name]

Agent log

1 INFO | jvm 1 | 2022/02/08 11:50:02 | 2022-02-08 11:50:02,952 INFO [0-BAM::agent_name::Agent:pool-3-thread-1] [AbstractArtifactManager] Unable to retrieve artifact artifact_name for PROJ-PLAN-1 via com.atlassian.bamboo.build.artifact.BambooRemoteArtifactHandler@19a898eb No matching Artifact found.

Cause

Bamboo is reporting that the artifact is not available for download. There could be multiple reasons for this, for example:

  • The artifact for the latest build was deleted

  • The artifact for the latest build was tampered with or blocked (i.e. file permissions)

  • Something unexpected changed in the configuration that made the artifact download task obsolete.

  • Other

Solution

The solution of this problem could be solved by simply running a build again to generate the artifact.

Still having problems?

Contact Atlassian Support. We'll be happy to advise you. Please include as much detail as possible, where applicable:

  • Logs from the affected application (if applicable)

  • Screenshots of the error message (if they're not covered in logs)

  • Information about the steps you've taken previously

Updated on March 12, 2025

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