Analyse File System Problems on Windows - MS Process Monitor

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Bamboo or a bamboo plugin such as clover may have file system access issues.

Files and/or directories cannot be accessed or created or deleted.

Cause

Oftentimes other windows processes such as virus scanners or backup tools hold the file system object so it cannot be access

Resolution

Start the Windows Process Monitor and configure it to point to the problematic directory.

Updated on April 8, 2025

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