Automation: Unable to Update Field When Creating Work items (Jira Cloud)
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Automation for Jira isn't able to update all fields when creating a work item.
Diagnosis
An automation rule for creating Jira work items and updating certain fields might not work properly and end up giving this error after work item creation.
Unknown fields set during create, they may be unavailable for the project/type. Check your custom field configuration. Fields ignored -
Field 1, Field 2
Issues created successfully
<Issue key>
Cause
The fields that failed to get updated are not present in the create work item screen of the work item that was created by the Automation.
Solution
Add the fields that failed to update to the Create Work Items screen of the work item type being created by Automation.
Updated on May 8, 2025
Was this helpful?
Still need help?
The Atlassian Community is here for you.