Unable to flag issues using the automation rule

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

This article provides details on the scenario when an automation rule is configured to flag issues using the Edit Issues Action and fails to do so.

Diagnosis

In the Audit logs, the following error would be observed:

Unknown fields set during the edit, they may be unavailable for the project/type. Check your custom field configuration. Fields ignored - Flagged 

Cause

This is observed if the Actor for the automation rule to flag issues is updated i.e. if the actor isn't set to Automation for Jira.

If the rule actor is set to User A (this could be a different Atlassian account) instead of Automation for Jira, then we see the error in the audit logs that the flagged field is not added to the screen. However, by logging into Jira as User A, we are able to add a flag on the issue even though the "Flagged" field is not added to the screen. This is specific to automation not being able to perform the edit without the field added to the screen for any other user apart from the connect addon user "Automation for Jira". This is due to a security limitation with overrideScreenSecurity where only the user of the Connect Add-on is able to edit fields that are not on the screen.

Solution

To address this issue, it is necessary for one of the two following conditions to be met:

  1. In the case where the actor is configured differently than 'Automation for Jira', you must add the 'Flagged' field to the Edit Screen. This will enable the flagging of issues when the actor in the automation rule is set differently.

  2. Alternatively, you could adjust the Actor for the rule to be 'Automation for Jira'. This adjustment should enable the flagging feature to operate as anticipated.

Updated on May 31, 2024

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