The ScriptRunner action shows the warning "Disabled third party extension for Automation for Jira?" when configuring an automation rule

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The purpose of this knowledge article is to describe a scenario where the ScriptRunner action cannot be used in Jira automation rules, due to the warning shown below, and how to fix it:

Issue replication locally

Note that this article is only applicable for Jira applications that have the third-party add-on ScriptRunner for Jira installed since the action "Execute a ScriptRunner script" comes from this add-on.

Diagnosis

  • Generate a HAR file, or check the browser Network tab while loading the page Project Settings > Automation for any project

    • Look for a request that is sent to the invalid endpoint /secure/undefined/rest/wrm/2.0/resources that returns the 404 Not Found HTTP error

Invalid URL
  • Enter plugin safe mode in the ⚙ > Manage Apps > Manage Apps, then re-enable the ScriptRunner add-on and check if the warning goes away

    • If the warning goes away, then this article is relevant

    • Make sure to exit plugin safe mode, otherwise all the 3rd party add-ons will remain in the disabled state

    • If your operations rely heavily on 3rd party add-ons, we highly recommend to:

      • Either perform this test on a clone/test Jira environment

      • Or to perform it outside business hours

Cause

There is a 3rd party add-on that is preventing Automation For Jira from properly loading the action "Execute a ScriptRunner script" that comes from ScriptRunner. So far, only the 2 add-ons below have been reported to cause this issue, but there might be others:

Solution

The solution consists of 2 main steps described below.

Step 1 - Identify the problematic add-on

  1. Go to the page ⚙ > Manage Apps > Manage Apps

  2. Disable each 3rd party add-on 1 by 1

  3. Whenever you disable 1 add-on, try to configure a new automation rule and check if the warning still appears when loading the action "Execute a ScriptRunner script"

    1. If the warning is still there, go back to the previous step and continue disabling add-ons

    2. If the warning goes away, take note of the last add-on that was disabled, as it is the one that was causing the issue

  4. Once you identified the problematic add-on, re-enable all the add-ons

Step 2 - Disable the problematic add-on or reach out to their support team

You have 2 options here:

  • Either disable the problematic add-on, so that you can configure the automation rule using the action "Execute a ScriptRunner script"

  • Or, if disabling this add-on is not an option, please reach out to the add-on support team so that you can get assistance on this issue since 3rd party add-ons are not supported by Atlassian. You can find the link to the add-on support portal on its listing on the Atlassian Marketplace

Updated on May 31, 2024

Still need help?

The Atlassian Community is here for you.