Tempo custom field values are not appearing in Automation rules

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you are using the Third party app, Tempo timesheets, you might see that not all values that exist for tempo field is showing under the edit issues rule.

Diagnosis

This is because of the existing limitation in Automation, where a tempo account does not work with more than 1000 accounts.

Cause

Automation always makes the API call below irrespective of the search string

https://<site name>.atlassian.net/rest/api/2/field/io.tempo.jira__account/option?maxResults=1000

This is currently logged as a bug. The details can be seen from this link Automation limit with Tempo Accounts

Solution

You can add the value of the tempo account through Advance edit for Automation in an edit issue field section as shown below.

Use Edit issue action

This is the JSON that you can use to add the tempo account value. In the example below "customfield_12401" would be the custom field ID of the tempo account and "ID number" needs to be replaced with the ID number of the value field.

1 2 3 4 5 { "fields": { "customfield_12401": "ID number" } }

Updated on May 31, 2024

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