An automation rule fails with the error "The selected resolution cannot be chosen during this action. (resolution)"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This knowledge base article describes how to fix automation rules (coming from the add-on Automation for Jira) that fail with the error The selected resolution cannot be chosen during this action. (resolution), which can be found in the Automation Audit logs:

Automation error

Diagnosis

The automation rule is configured to transition an issue to a certain status, while setting the resolution field to a certain value:

  • Either by using the option Choose fields to set...

Transition issue action
  • Or by using the option Additional fields:

Use additional fields

The transition that is executed by the Automation rule is configured with the property key jira.field.resolution.include, which is used to only allow certain resolution IDs to be set during the transition:

Add property key
  • The ID of the resolution set during the automation rule is not included in that list. To check the ID of a resolution field, you can follow the steps below:

  • Go to ⚙ > Issues > Resolutions, and click on Edit next to the Resolution:

Edit resolution field
  • Look for the ID at the end of the URL:

Pick the resolution ID from the URL

Cause

The resolution value that the Automation rule is trying to set is not allowed by the transition, since it is not included in the list of IDs configured in the property key jira.field.resolution.include.

Solution

Option 1

Add the resolution ID to the property key jira.field.resolution.include (to get the ID of the resolution, please refer to the diagnosis steps).

Option 2

Modify the Automation rule, so that it either sets the resolution field to a value that is allowed by the transition, or so that it does not set the resolution field (depending on your use case).

Updated on May 31, 2024

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