Automation | Rule fails with error "A JQL search in this automation rule has exceeded the allowed maximum number of issues"
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Automation rules can also fail after hitting service limits. This article will discuss approaches to avoid service limit throttling due to JQL processing.
Diagnosis
The error that can be observed in the audit log of the automation rule is: A JQL search in this automation rule has exceeded the allowed maximum number of issues to retrieve per search. Only the first issues up to the following limit were processed:1000
Cause
The error implies that scheduled JQL search that isn't streamlined enough and returns more than 1000 issues as mentioned in the Service Limit Document.
Solution
Setup the JQL query in a way that can reduce the returned search results. Example, add the specific issue Type to narrow the search, put additional conditions if looking for specific fields values in particular, specify the status or limit the issue creation date.
Sample JQL :
"Start Date[Date]" < {{now.jiraDate}} AND status != Done AND (Custom_field_XXXX > 0 AND "ABCD_Field" in (Pending))
Further reading
For additional information on optimizing JQL as well JQL, please refer to the following articles:
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