Resolve JQL Search Error in Jira Automation (Cloud)
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Automation rules can also fail after hitting service limits. This article will discuss approaches to avoid service limit throttling due to JQL (Jira Query Language) processing.
Diagnosis
The error that can be observed in the audit log of the automation rule is: A JQL search in this automation rule has exceeded the allowed maximum number of work items to retrieve per search. Only the first work items up to the following limit were processed: 1000
Cause
The error implies that scheduled JQL (Jira Query Language) search that isn't streamlined enough and returns more than 1000 issues as mentioned in the Service Limit Document.
Solution
Configure the JQL query so that the returned search results are narrowed down to a smaller list.
Example
Add the specific work item type to narrow the search, put additional conditions if you're looking for specific field values, specify the status, or limit the issue creation date.
Sample JQL :
"Start Date[Date]" < {{now.jiraDate}} AND status != Done AND (Custom_field_XXXX > 0 AND "ABCD_Field" in (Pending))
Additional Information
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