Automation rule | Jira smart value issue.description not fetching the issue description in auto email
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
The issue description field is not being copied and returned via email. Email received and audit log has an empty value for the Description field.
The smart value used in the email body in the automation rule :
SMART VALUE FOR THE DESCRIPTION FIELD: {{issue.description}}
Diagnosis
Test the smart value with other issue type and project as well to reproduce the problem.
Check whether there is any custom field with same name "Description" exists.
Try to review the fields on the issue with rest api: https://YOURSITENAME.atlassian.net/rest/api/3/issue/ISSUEID-XXXX?expand=names check whether there are two description field display on the issue with different id.
Cause
The behaviour could be observed commonly when there is duplicate custom field exists. The smart value mentioned above is for system field not for custom field. Thus the smart value was resulting empty or null value as output.
Solution
If you wish to get the value of the custom field then please change the smart value to the below value :
SMART VALUE FOR CUSTOM FIELD: {{issue.customfield_XXXX}}
NOTE: If custom field named "Description" is not in use then suggest to remove this field from the site or project so that there would not be any confusion in future.
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