'Field value changed' trigger in Automation doesn't support 'Epic Link' field
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
While setting up an automation rule, 'Epic Link' field is not present in 'Field value changed' trigger.
Diagnosis
'Epic Link' field is missing under the 'Field value changed' trigger. The only fields present in relation to Epic are 'Epic Color', 'Epic Name' & 'Epic Status'.
Cause
This is expected behavior per the current design.
Solution
Instead of 'Field value changed' trigger, use 'Issue updated' trigger and follow the below steps:
Trigger
'Issue Updated'
Condition 1: 'Issue fields condition'
Issuetype should not be Epic, or add specific issuetype(s) where you need to execute the rule.
Condition 2 : 'Advanced compare condition'
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Action: Add the action you would like to be performed in the end.
Sample Rule based on the above-stated steps:
Additional information
To have this requirement implemented, we have below feature request to restrict sprints per project created:
By adding yourself as a watcher, you will receive all communications done on the progress of this. You can refer to our feature request policy for more information about how we plan for the new features.
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