Failed to retrieve selections from the dropdown, when trying to edit the 'Epic Link' field from Automation
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When editing the 'Epic link' field of an issue from Automation's Edit Issue action, the dropdown does not return any Epic information, no selections are retrieved.
Diagnosis
NA
Cause
Renaming the system default name of the Epic Issue type is known to cause this behaviour. This can further be verified by running the below API call:
https://<your_site>.atlassian.net//rest/api/2/search?fields=summary&jql=type%3DEpic
This would result in the following error:
{ "errorMessages": [ "The value 'Epic' does not exist for the field 'type'." ], "warningMessages": [] }
Solution
The Automation for Jira is unable to recognize the custom name given to the Epic Issue type.
Reverting the name of the Issue type to Epic will resolve this and a list of available Epics will be displayed in the dropdown to be selected for Editing.
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