Automation | Error : Unknown fields set during create, they may be unavailable for the project/type. Check your custom field configuration. Fields ignored - Reporter (reporter)
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Learn why and how to fix it when your automation to create work items/subtasks fails, or works irregularly, with the following error shown in the logs: Unknown fields set during create; they may be unavailable for the project/type. Check your custom field configuration. Fields ignored -Reporter (reporter).
Diagnosis
The following error is seen in the audit logs:
Unknown fields set during create, they may be unavailable for
the project/type. Check your custom field configuration. Fields ignored -Reporter (reporter)
Cause
First, ensure the reporter's value is correctly parsed through any smart values, JSON, or "copied from the trigger/current issue" in your rule. This would indeed cause the error to happen as the rule won't be able to set the field.
If all these settings are properly configured, there are some other mapped causes for this issue:
The reporter field is missing on the Work Item Create screen
The Reporter Field is hidden for the Screen/Project
The automation rule is sometimes successful, but sometimes, it errors out. The automation rule Actor has been set as "User who triggered the event."
Solution
The reporter field is missing on the Work Item Create screen
If the field is not part of the create screen, it means the field can't be accessed when creating new work. The rule can't access it.
Go to Project Settings > Screens.
Click the screen associated with the Create Issue operation in the work type used by the automation.
Confirm the Reporter field is not included in the screen.
Add the field to the screen.
Refer to Associate fields with screens in Jira Cloud.
The Reporter Field is hidden for the Screen/Project
If the field is hidden in the project, the automation rule won't be able to access it.
Go to Project Settings > Fields.
Click the pencil icon to edit the field scheme associated with the project.
Search for the Reporter field.
Under the Actions column, check if the field is marked as hidden.
If you can see a button 'Hide,' it means the field is not hidden.
If you can see an option 'Show,' it means the field is hidden. Click it to unhide it.
Refer to Change a field configuration.
The automation actor is the user who triggered the event
If the user who triggered the rule doesn't have permission to "Modify Reporter" in the project, the rule will throw this error. This could explain why the rule works in some cases (when the actor has the necessary permission) and fails in others (when they don’t).
Go to Project Settings > Permissions.
Search for the Modify Reporter permission.
Confirm that the user who triggered the rule is not included in this permission.
Edit the project's permissions to include the user.
Refer to Manage project permissions.
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