Bulk operations with automation does not work as expected
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When doing any bulk operations to update a certain field on multiple issues at the same time, we tend to see that the field update does not happen as expected. There may be some issues where the update would have not completed.
Diagnosis
N/A
Cause
The operations are taking place too quickly that the automation could not complete the rule execution for all the fields at the same time.
Solution
Step 1: Access the rule in question.
Step 2 : Immediately after the trigger, add an action → re-fetch issue data → save
Step 3 : Publish the rule.
The re-fetch action will fetch the information from the issues again just not to miss any of the issues.
Information
For field updates using Bulk Action, the automation will not trigger if the "Field Value Changed" with "Edit Issue" or "Assign Issue" operation is set. This is a current limitation and here are the tracked it AUTO-104 - Better support for bulk actions in Automation
Was this helpful?