Automation : User input window not popping up when using Manual Trigger

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Manual triggers in automation also gives an option to let user add data to specific fields. To enable user inputs below prompt should be checked:

Automation Rule Manual Trigger

When the rule is run, a prompt will show up with specified fields in automation rules. In this case, when manual rule is run, it does not pop up any window. In rule audit logs also we see rule does not run.

Diagnosis

During diagnosis, HAR logs were collected and investigated. Below error was noticed:

1 Cannot set a numeric property on an object
har file error

Cause

The variables created in rule trigger were named containing only integers. Example shown below:

linked ticket variable window

Solution

Variable name should be a string and not just an integer. Using string values will resolve the rule issue.

Updated on July 19, 2024

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