Automation Rule| With Automation Rule incorrect user(doesnot belong to the setup Role) is being assigned to Issue.
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
An automation rule that has been setup to assign the issue to a particular Role user based on the condition is assigning the issues to the user who is not part of the defined Role in the rule.
Diagnosis
Issue "ABC-123" was assigned to the user "Testuser1" who is not part of Role "Jira-Test-Role" in the project "Example"
Validate the user "Testuser1" is part of Role "Jira-Test-Role" in the project "Example"
Verification steps followed
User does not exist in the Role on Project settings
Go to the Project setting
People > review User and associate Role
user does not exist here.
No other automation rule has been executed to assign the issue.
Workflow does not have user assignment defined in the post function.
No other script has been executed to perform this operation.
Cause
Such behaviour of assignment to a user(incorrectly) has been observed when the said user is part of the Default user or Default group for the Role on Global Project Role.
Example: User(Testuser1) could be part of the Role "Jira-Test-Role" in the Project Role in the global setting.
Solution
Go to your Jira site check click on the gear button next to the profile > select System > Go to "Project Role" under System.
Then click on "Manage Default Member" for the "Jira-Test-Role" role.
Then check whether the user "Testuser1" is mentioned under Default User or the group that is mentioned under Default group has user "Test User".
Sharing snippet for reference:
Check the Role in Project role(global), If the user exists there please remove it from the default user or Default group and test the automation rule again.
Yet if the issue persists please reach out to support via: https://support.atlassian.com/contact/
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