Automation | Automation rule is not returning "Description" value in audit log and send email via smart value.

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The issue description field is not being copied and returned via email and audit log when the below smart value is being used :

  • {{issue.description}}

Diagnosis

Audit log showing empty result for Description field
  • Email content also has the same behaviour.

Cause

Description is a system field, the above smart value is used to fetch the value of the system field "Description"

The above behaviour has been observed when there is a custom field available with the same name on the instance.

Solution

The recommendations to mitigate this problem are:

  • Either you can remove or rename the custom field and then try to update the Description field(system field) on the issue then it should be returned in the email.

  • Or you can use the smart value below with the value, sharing the document for more insights:

    • {{issue.[Custom Field]}}

Updated on May 31, 2024

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