Jira Automation rule returns empty Description when using a smart value

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

The issue description field is not being copied and returned via email and audit log when the smart value {{issue.description}} is used.

Diagnosis

  • As per the document: https://support.atlassian.com/cloud-automation/docs/jira-smart-values-issues/ the smart value to fetch the value of the description of the issue is {{issue.description}}

  • Validate the field "Description" and its value on the issue (captured in the audit log)via API call: https://<your_site>.atlassian.net/rest/api/3/issue/<issue_key>?expand=names

  • In the audit log value is empty as the screenshot below indicates:

Audit log showing empty result for Description field
  • Email content also has the same behavior

Cause

Description is a system field, the above smart value is used to fetch the value of the system field "Description"

The above behavior has been observed when there is a custom field available with the same name on the instance.

Solution

The recommendations to mitigate this problem are:

  • Remove or rename the custom field and then try to update the Description field (system field) on the issue then it should be returned in the email

  • Use the smart value below with the value, following the format indicated in our documentation

    • {{issue.[Custom Field]}}

Updated on November 6, 2025

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