Automation for Jira : Automation rule fails due to unexpected JQL error

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

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*Except Fisheye and Crucible

Summary

Using a JQL search in a scheduled trigger for Automation for Jira might result in execution errors when it's not able to find any results due to user permissions.

Diagnosis

The automation rule will execute but finish with failures running the scheduled JQL search.

Cause

On the rule details view, the field "actor" is :

  • Set to a user that does not have enough access rights to run the search.

  • Inactive user.

The behavior can be tested by logging in to Jira using the same user account used for "actor" field and running the JQL search manually using the menu Issues → Search for issues Issues.

Solution

  1. Extended the "actor" user permission by allowing "Browse project" permission on all the projects that should appear in the search result.

  2. Use a different user with more privileges to see the search results.

Updated on May 31, 2024

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