Automation | Failed to get licences from JSD due to user not authorized (Jira Software - Opsgenie)

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When creating an automation rule, the "Assign Issues" action component provides the ability to assign the issue to an on-call responder retrieved from a Team in Opsgenie. However, in certain scenarios, the user is unable to fetch the teams from within the action component and the below error is seen in the UI:

ERROR - Failed to get licences from JSD due to user not authorized

Diagnosis

Request:

1 2 3 Request URL:https://<siteURL>/gateway/api/jsd/escalator/<opsgenie connector ID>/api/teams?keyword=Request Method:GET Status Code:401

Response :

1 2 3 4 5 { "errorMessage": "Failed to get licences from JSD due to user not authorized", "errorKey": "jsd.escalator.error.licences.licences.jira.not.authorized", "statusCode": 401 }

Cause

  • Insufficient permissions on Opsgnie

  • Product subscription requirement

Solution

  • Insufficient permissions on Opsgnie:

Please ensure that the user who is retrieving the teams from Opsgenie from within Jira Software Automation needs to have access (user or admin) in Opsgnie in order to successfully retrieve the teams and schedules

  • Product subscription requirement:

As per the current design, it is possible to retrieve teams in Automation for Jira only if there is an active Jira Service Management product license on the site. If you have a Jira Software subscription and an opsgenie subscription, then retrieving the Opsgenie teams will fail with the above-described error message. As a workaround, you can add Jira Service Management to your site (A Free JSM license is sufficient for the automation rule to fetch the Opsgenie teams).

Updated on May 31, 2024

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