Automation If-Else block is not passing
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Automation If-Else block is not passing even though field conditions are met for the ticket.
Diagnosis
The automation rule will execute, but may say that no conditions were met:
![Field condition rule](https://images.ctfassets.net/zsv3d0ugroxu/18BBuloLo0AJAiQCz6RQCe/c04eee1a0ffcd3da777bf9c6e31ce2c9/field_condition_rule.png)
While the ticket does have the required condition value:
![Components](https://images.ctfassets.net/zsv3d0ugroxu/01BksEGB0oi8d8a3Ew4QO6/c6cd82a9d5808acb916f7cfcf3c51961/image2021-6-11_11-2-3.png)
Verify the letter case of the expected value on the field condition within the automation rule:
![Verify the letter case on the field condition](https://images.ctfassets.net/zsv3d0ugroxu/19xvqfH0CSMPO59YBoFnRV/f83cd87abdd80656a0810329cb81f2fb/issue_fields_condition.png)
You will see that it is different from the ticket and actual component name, verify the current field value for the system or custom field:afaz
![Verify the current field value for the system/custom field](https://images.ctfassets.net/zsv3d0ugroxu/7AwIIoLap20fXfBRCtE8wb/31e7144e99ecc320a772f7526ca30b07/image2021-6-11_10-58-52.png)
Cause
The original system or custom field value was changed after it was added to the condition. When values are added to automation rule conditions, they become simple strings and the condition needs an exact match.
So this can happen if the value was completely changed, or just the letter case was changed.
Solution
Remove and re-add the field value to the condition.
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