Automation rule error: missing configured field '[object Object]'
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Resolve errors in automation rules: Learn how to identify and fix component errors in your automation setup.
Could not find configured field '[object Object]'. It may have been deleted
Diagnosis
N/A
Cause
This error happens when a component (such as the "Work Item Fields Condition") in an automation rule contains a reference to a custom field that does not exist in the Jira application. There can be two scenarios where this situation can happen:
Root Cause 1
The field existed when the automation rule was written, but later, a Jira Admin user deleted it via the Cog icon > Work items > Custom Fields.
Root Cause 2
The field never existed, and the rule was imported through the JSON export (via the Cog icon > System > Automation rules > ••• > Import rules) from a different Jira application where the field exists.
Solution
Regardless of the root cause, the resolution steps are the same:
Go to the Cog icon > Work items > Custom Fields and create the missing custom field.
Edit the component in the automation rule that is showing the error, and add the new custom field that was created.
This step will differ slightly depending on the type of component that is affected by the error.
For example, in the case of a Work Item Fields Condition component, use the Fields dropdown and select the new custom field.
Was this helpful?