An automation rule shows the error "Could not find configured field '[object Object]'. It may have been deleted" in its configuration

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Summary

An automation rule shows the error below in one of its component:

1 Could not find configured field '[object Object]'. It may have been deleted
Automation Rule

Diagnosis

N/A

Cause

This error happens when a component (such as the "Issue Fields condition") in an automation rule contains a reference to a custom field that does not exist in the Jira application. There can be 2 scenarios where this situation can happen:

  • Root Cause 1 : The field existed at the time the automation rule was written, but later the field got deleted by a Jira Admin user via the page ⚙ > Issues > Custom Fields

  • Root Cause 2 : The field never existed, and the rule was imported through the JSON export (via the page ⚙ > System > Automation rules > ... > Import rules) from a different Jira application where the field exists

Solution

Regardless of the root cause, the resolution steps are the same:

  • Go to the page ⚙ > Issues > Custom Fields and create the missing custom field

  • Edit the component in the automation rule that is showing the error, and add the new custom field that was created

    • This step will differ slightly depending on the type of component that is impacted by the error

    • For example: in case of an Issue Fields Condition component, use the Fields dropdown and select the new custom field

Updated on November 4, 2024

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