Setting up Application Link results in ServerID already being used

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Trying to set up an Application Link with an Atlassian application results in:

1 The ServerID reported is already being used for an Application Link. This may be because you have multiple applications with the same ServerID.

Diagnosis

This error may occur when trying to migrate any Atlassian application server or setting up a development environment with existing data. The stack trace may look like the following:

1 2 java.lang.IllegalArgumentException: Application with server ID 30a2a7ec-3233-30e9-87a2-edf1dfc0c4e4 is already configured at com.atlassian.applinks.core.DefaultApplicationLinkService.addApplicationLink(DefaultApplicationLinkService.java:272)

Cause

Application Links uses the Server ID as a unique identifier.

Solution

Workaround

Manually change the Server ID by following:

Updated on April 17, 2025

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