While Setting a Service Desk Mail Handler we get an error "This email address is already in Use"

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Problem:

In JIRA Service Desk Cloud, while setting a mail handler to support@domain.com we get and error, this email address is already in use by another project. However, the mail address is not configured as a mail handler anywhere in any project.

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Cause:

This issue occurs is the first part of the mail address of the handler matches that of a default cloud mail handler in another project. For example, in an instance Project A has a default cloud mail handler as support@xyz.atlassian.net and for Project B we try to configure a custom mail handler support@domain.com. Though support@domain.com does not exist in any project, we will get this error as the first part of mail handler address of both projects is "Support".

Resolution:

  • Go to the Project A --> Project settings

  • Email requests

  • Edit the Cloud email address support@xyz.atlassian.net to a test address (Temporarily)

  • Once the value Support is free, Create the Custom mail address in the required project.

  • Once done Update the Cloud Email address in the Project A to support@xyz.atlassian.net.

Updated on April 11, 2025

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