Unable to invite user, restore access or add a user to a group in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Unable to invite a user, restore access, or add a user to a group with error: Action could not be performed because you've reached the maximum number of users for your plan. Upgrade to grow your team.

Diagnosis

When trying to activate a suspended user or invite a new user to an instance, it fails with an exception: "Action could not be performed because you've reached the maximum number of users for your plan. Upgrade to grow your team."

Open the developer tool(keyboard shortcut F12) and try to restore access to the suspended user, invite the user, or add the user to a default group that grants access to the product, you will see an exception like the one below in Activate, Invite, or Group

{     "key": "licenceExceeded",     "context": {         "message": "Licence exceeded: LicenceCheckHardLimitFailure{licenceCheckProducts=[LicenceCheckProduct{skippedLicenceCheck=false, productARI=ARI{resourceOwner=jira-product-discovery, resourceType=site, resourceId=xxxxx}, availableLicencesWithinSoftLimit=0, availableLicencesWithinHardLimit=0, requiredSeats=1}]}",         "reason": "[jira-product-discovery]"     } }

Cause

Multiple products are allocated to the user and the number of licenses for one or more products has reached the maximum limit.

Solution

  • Remove the maximum licensed product while inviting the user.

  • Do not grant access to the group which is the default group for the product.

  • While trying to restore the access, remove the product or the group and then restore the user access.

Updated on April 14, 2025

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