Resolving 'Too Many Results' error when exporting users

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Using the original user management experience, site admins are unable to export users when filtering users based on product access. You are presented with the error message "Too Many Results" Refine your filters and try again. If this issue persists, contact our support team.

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Environment

All Cloud Products

Diagnosis

After checking the HAR logs, you can see an error called "MaxProductAccessGroupExceeded" which means that the product had more groups on the Product Access page.

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Cause

Groups that give product access to a particular product should not be more than 20 if you want to use a filter to extract users.

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Solution

  1. Remove all the filters from the Users page

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  2. Click on the Export Users button on the right

  3. Select the options as seen in the attached screenshot

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  4. Download the CSV file that you would have received in your email

  5. Open the downloaded file in Excel, and filter the results based on the product roles for a specific product.

Updated on February 28, 2025

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