Payload for custom variable is too large error in Automation for Jira

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

This article covers automation rules impacted by the error "Payload for custom variable is too large, try reducing the amount of data stored in your custom smart variable" in the rule's execution audit logs.

Diagnosis

The error occurs with components such as Send web request and Branches that process data from variables or actions such as Lookup issues.

Cause

This is due to Automation components having limits on the amount of data that can be passed to them. In the example of the Send web request action even though the data may be filtered prior to being transmitted, the overall data size that is sent for the component to process exceeds these limits.

Solution

In order to resolve the issue, the volume of data passed to the impacted component needs to be reduced. Depending on the configuration of the automation rule, this can be done by:

  1. Narrowing the scope of a JQL query that is used with say a Lookup issues action or the Scheduled trigger that uses JQL to retrieve issues

  2. If the JQL cannot be scoped any further but can be split into logical segments, such as a query that checks multiple projects or multiple issue or request types, splitting the automation rule up into individual rules that use a single project, issue or request type can help mitigate the issue

For additional information on optimizing JQL queries please see JQL optimization recommendations.

Updated on March 18, 2025

Still need help?

The Atlassian Community is here for you.